본문 바로가기

분류 전체보기174

[Baekjoon/Python] No.4673 Self Numbers No.4673 Self Numbers Problmes In 1949 the Indian mathematician D.R. Kaprekar discovered a class of numbers called self-numbers. For any positive integer n, define d(n) to be n plus the sum of the digits of n. (The d stands for digitadition, a term coined by Kaprekar.) For example, d(75) = 75 + 7 + 5 = 87. Given any positive integer n as a starting point, you can construct the infinite increasing.. 2020. 4. 23.
[백준/파이썬] No.15596 정수 N개의 합 No.15596 정수 N개의 합 문제정수 n개가 주어졌을 때, n개의 합을 구하는 함수를 작성하시오. Python 2, Python 3, PyPy, PyPy3: def solve(a: list) -> inta: 합을 구해야 하는 정수 n개가 저장되어 있는 리스트 (0 ≤ a[i] ≤ 1,000,000, 1 ≤ n ≤ 3,000,000)리턴값: a에 포함되어 있는 정수 n개의 합 (정수) Solution def solve(a): ans = sum(a) return ans 2020. 4. 23.
[백준/파이썬] No.11022 A+B - 8 No.11022 A+B - 8 문제 두 정수 A와 B를 입력받은 다음, A+B를 출력하는 프로그램을 작성하시오. 입력 첫째 줄에 테스트 케이스의 개수 T가 주어진다. 각 테스트 케이스는 한 줄로 이루어져 있으며, 각 줄에 A와 B가 주어진다. (0 < A, B < 10) 출력 각 테스트 케이스마다 "Case #x: A + B = C" 형식으로 출력한다. x는 테스트 케이스 번호이고 1부터 시작하며, C는 A+B이다. 예제 입력 5 1 1 2 3 3 4 9 8 5 2 예제 출력 Case #1: 1 + 1 = 2 Case #2: 2 + 3 = 5 Case #3: 3 + 4 = 7 Case #4: 9 + 8 = 17 Case #5: 5 + 2 = 7 Solution cases = int(input()) for.. 2020. 4. 22.
[백준/파이썬] No.2739 구구단 No.2739 구구단 문제 N을 입력받은 뒤, 구구단 N단을 출력하는 프로그램을 작성하시오. 출력 형식에 맞춰서 출력하면 된다. 입력 첫째 줄에 N이 주어진다. N은 1보다 크거나 같고, 9보다 작거나 같다. 출력 출력형식과 같게 N*1부터 N*9까지 출력한다. 예제 입력 2 예제 출력 2 * 1 = 2 2 * 2 = 4 2 * 3 = 6 2 * 4 = 8 2 * 5 = 10 2 * 6 = 12 2 * 7 = 14 2 * 8 = 16 2 * 9 = 18 Solution a=int(input()) for i in range(1,10): print("%d * %d = %d" %(a, i, a*i)) 2020. 4. 22.
[Probability & Statistics] 4. Bayes’ Rule, Concept of a Random Variable Probability & Statistics Bayes’ Rule, Concept of a Random Variable Chapter 2. Probability Section 2.7 Bayes’ Rule Figure 2.12 Venn diagram for the events A, E and E ' Theorem 2.13 : Rule of Total Probability ★ If events B1,B2, . . . ,Bk constitute a partition of the sample space S and P(Bi) 6= 0 for i = 1, 2, . . . , k, then for any event A in S: Figure 2.14 Partitioning the sample space S Examp.. 2020. 4. 18.
[Probability & Statistics] 2. Sample Space, Events, Counting Sample Points Probability & Statistics Chapter 2. Probability Section 2.1 Sample Space Definition 2.1 Sample Space : the set of all possible outcome of a statistical experiment Figure 2.1 Tree diagram for Example 2.2 Section 2.2 Events Definition 2.2 Event : a subset of a sample space Definition 2.3 Comlement : an event A with respect to S is the subset of all elements of S that are not in A Definition 2.4 In.. 2020. 4. 18.
[Probability] Intro to Statistics and Data Analysis Probability Intro to Statistics and Data Analysis Why study probability/statistics? • many fields of science and industry uses probabilistic/statistical methods : manufacturing, finance, medicine, computer engineering, insurance, physics... • scientific experiments and observations Fundamental relationship between probability and statistics 2020. 4. 18.
[백준/파이썬] No.1330 두 수 비교하기 No.1330 두 수 비교하기 문제두 정수 A와 B가 주어졌을 때, A와 B를 비교하는 프로그램을 작성하시오.입력첫째 줄에 A와 B가 주어진다. A와 B는 공백 한 칸으로 구분되어져 있다.출력첫째 줄에 다음 세 가지 중 하나를 출력한다.A가 B보다 큰 경우에는 '>'를 출력한다.A가 B보다 작은 경우에는 '') elif A < B: print(' 2020. 4. 18.
[백준/파이썬] No.2753 윤년 No.2753 윤년 문제연도가 주어졌을 때, 윤년이면 1, 아니면 0을 출력하는 프로그램을 작성하시오.윤년은 연도가 4의 배수이면서, 100의 배수가 아닐 때 또는 400의 배수일 때이다.예를 들어, 2012년은 4의 배수이면서 100의 배수가 아니라서 윤년이다. 1900년은 100의 배수이고 400의 배수는 아니기 때문에 윤년이 아니다. 하지만, 2000년은 400의 배수이기 때문에 윤년이다.입력첫째 줄에 연도가 주어진다. 연도는 1보다 크거나 같고, 4000보다 작거나 같은 자연수이다.출력첫째 줄에 윤년이면 1, 아니면 0을 출력한다.예제 입력 1 2000예제 출력 1 1 Solution a = int(input()) if (a % 4 == 0 and a % 100 != 0) or a % 400 ==.. 2020. 4. 18.
[백준/파이썬] No.11650 좌표 정렬하기 No.11650 좌표 정렬하기 문제 2차원 평면 위의 점 N개가 주어진다. 좌표를 x좌표가 증가하는 순으로, x좌표가 같으면 y좌표가 증가하는 순서로 정렬한 다음 출력하는 프로그램을 작성하시오. 입력 첫째 줄에 점의 개수 N (1 ≤ N ≤ 100,000)이 주어진다. 둘째 줄부터 N개의 줄에는 i번점의 위치 xi와 yi가 주어진다. (-100,000 ≤ xi, yi ≤ 100,000) 좌표는 항상 정수이고, 위치가 같은 두 점은 없다. 출력 첫째 줄부터 N개의 줄에 점을 정렬한 결과를 출력한다. 예제 입력 5 3 4 1 1 1 -1 2 2 3 3 예제 출력 1 -1 1 1 2 2 3 3 3 4 Solution N = int(input()) dot_list = [] for _ in range(N): do.. 2020. 4. 15.